2018年11月11日

FFmpeg rev.92405 ダウンロード

FFmpeg最新版(2018/11/11現在)、rev.92405(e24a754916)のWindows用バイナリを置いておきます。

一般用は「--enable-w32threads」、w32threadsはWindows XPがサポート対象外になったため、レガシー用は「--enable-pthreads --disable-w32threads」にしています。
その他、レガシー用に「--disable-dxva2」を追加している以外は共通です。
レガシー用のpthreadsライブラリは、mingw-w64のwinpthreadsを使用しています。
ffplayとffprobeは、レガシー用のconfigureオプションでビルドしています。

・携帯動画変換君用パッチ適用版(time表示が秒単位、-flags2などの旧オプションも使用可、など)
ffmpeg_bin_legacy-92405.zip (主にWindows XP用)
ffmpeg_bin_generic-92405.zip (一般用)

ffplay_bin-92405.zip
ffprobe_bin-92405.zip

・オリジナル版
ffmpeg_bin_legacy_orig-92405.zip (主にWindows XP用)
ffmpeg_bin_generic_orig-92405.zip (一般用)


以下のライブラリをアップデートしました。
nasm-2.14
libaom v1.0.0-903-g486cc9894
Kvazaar v1.2.0-128-g5c774c4
OpenH264 v1.9.0-20181105-git-30a196a
opus-1.3
libvpx v1.7.0-1339-g2ac954dfd
zimg-2.8


libaomについては、こちらを参照してください。
libaom AV1 Encoding Guide
https://trac.ffmpeg.org/wiki/Encode/AV1

zipファイルを解凍すると、ffmpeg.exeが出てきますので、携帯動画変換君のcoresフォルダに置くなり、単体で使うなりしてください。

携帯動画変換君のffmpeg.exeとは、オプションの互換性がありませんので、上書きする際はご注意ください。

FFmpegのビルドは、以下の記事を参考にしてください。
FFmpegのビルド (2014/02/17)

ビルド環境:MinGW gcc-8.2.0
binutils-2.31.1
mingw-w64-v6.0.0

各ライブラリのバージョンは、以下の通りです。
nasm-2.14
yasm-1.3.0
zlib-1.2.11
bzip2-1.0.6
libaom v1.0.0-903-g486cc9894
libbluray-1.0.2
libbs2b-3.1.0
libcaca-0.99.beta19
libcdio-2.0.0
libcdio-paranoia-10.2+0.94+2
game-music-emu-0.6.2
gsm-1.0.18
libilbc-2.0.3-dev-20160405-git-746f8e2
Kvazaar v1.2.0-128-g5c774c4
libmodplug-0.8.9.0
lame-3.100
OpenH264 v1.9.0-20181105-git-30a196a
openjpeg-2.3.0
opus-1.3
opencore-amr-0.1.4
vid.stab-v1.1-20180529-git-38ecbaf
vo-amrwbenc-0.1.3
gmp-6.1.2
nettle-3.4
gnutls-3.5.19
rtmpdump-2.4-20151223-git-fa8646d GnuTLS版
snappy-1.1.7
libogg-1.3.3
aoTuV Beta6.03 (2018)
libtheora-1.1.1
speex-1.2.0
twolame-0.3.13
libsoxr-0.1.3
libvpx v1.7.0-1339-g2ac954dfd
wavpack-5.1.0
libwebp-1.0.0
x264 rev.2935 git-545de2f (make fprofiled)
x265 2.8+74-fd517ae68f93
xvidcore-1.3.5
libiconv-1.14
freetype-2.9.1
expat-2.2.6
fontconfig-2.13.1
fribidi-1.0.5
libass-0.14.0
SDL2-2.0.5
xz-5.2.4
libxml2-2.9.8
zimg-2.8
mfx_dispatch-20180615-git-a0a966d


configureオプションは、以下のようにしています。
一般用は「--enable-w32threads」、レガシー用は「--enable-pthreads --disable-w32threads」にして、「--disable-dxva2」を追加している以外は共通です。

$ ./configure --enable-gpl --enable-version3 --enable-avisynth --enable-fontconfig --enable-gnutls --enable-libaom --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libilbc --enable-libkvazaar --enable-libmfx --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenh264 --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxvid --enable-libxml2 --enable-libzimg --enable-opengl --enable-w32threads --disable-debug --pkg-config-flags=--static --extra-ldflags=-static --extra-cflags="-mtune=generic -mfpmath=sse -msse" --cpu=i686 --optflags="-O2 -finline-functions"
posted by あべちん at 17:41 | Comment(1) | TrackBack(0) | FFmpegダウンロード
この記事へのコメント
いつも提供ありがとうございます。
とても助かります。。。
Posted by とおりすがり at 2018年12月12日 02:20
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント:

認証コード: [必須入力]


※画像の中の文字を半角で入力してください。
この記事へのトラックバックURL
http://blog.sakura.ne.jp/tb/184916655
※言及リンクのないトラックバックは受信されません。

この記事へのトラックバック